[[Diary]]

//_WRITEBYNAKAX
天気:晴,血圧:146/94,体温:36.0℃,体重:62.5kg,歩数:,投稿:&new{2012-09-13 (木) 08:44:40};~
** URLメモ [#afdf50ea]
-[[Error parsing XML: unbound prefix  Manabin 's Lifelog>http://uky0426.wordpress.com/2011/03/24/error-parsing-xml-unbound-prefix/]] : Error parsing XML: unbound prefix : &color(purple){単純なうちミスなのだが、気づきにくいという。。。 android が androld になってたわ。。}; -- [[nakax]] &new{2012-09-13 (木) 22:48:57};
-[[Index of /p01d/toolkit/ - www5216u.sakura.ne.jp>http://www5216u.sakura.ne.jp/p01d/toolkit/]] : &color(purple){P-01D root化ツールの配布元}; -- [[nakax]] &new{2012-09-13 (木) 22:25:28};
-[[Using Hardware Devices | Android Developers>http://developer.android.com/intl/ja/tools/device.html]] : 
 Log in as root and create this file:
   /etc/udev/rules.d/51-android.rules.
 Use this format to add each vendor to the file:
   SUBSYSTEM=="usb", ATTR{idVendor}=="0bb4", MODE="0666", GROUP="plugdev" 
 : &color(purple){Linuxの場合は、この設定が必要なのね}; -- [[nakax]] &new{2012-09-13 (木) 20:10:10};
-[[実機を使ってデバッグする  Tech Booster>http://techbooster.jpn.org/andriod/environment/6104/]] : &color(purple){Android開発 実機でデバッグ!}; -- [[nakax]] &new{2012-09-13 (木) 20:09:20};
-[[eclipseにAndroid開発環境を構築しようと思ったのですが、ADT Plugin for Eclipse... - Yahoo!知恵袋>http://detail.chiebukuro.yahoo.co.jp/qa/question_detail/q1384242448]] : あきらめて、バージョンの新しいeclipseをダウンロードしてやってみたら出来ました。 : &color(purple){俺も Check for Updates やってもだめだったわ。結局 ubuntu の apt-get で入れた奴は消して、最新版をダウンロードしてきて、入れるしかないのかな}; -- [[nakax]] &new{2012-09-13 (木) 16:58:45};
--正直、エラーメッセージをみても どういうアクションしていいかわからんのが問題じゃないのかなぁ。。 つまりは経験不足なんだが。
-[[Android用開発環境構築メモ|システム開発ブログ(システム開発のアイロベックス|東京都新宿区の業務システム開発会社)>http://www.ilovex.co.jp/blog/system/cat820/android-4.html]] : 
 3.6でも同様に、Eclipseの[Help]-[Check for Updates]より、Eclipseコンポーネントの更新を行う事で解決できます。
 
 : &color(purple){先に、 Eclipse コンポーネントのアップデートをやってくださいってことか。}; -- [[nakax]] &new{2012-09-13 (木) 16:47:46};
-[[ひとこと書いてもいいですか Ubuntu9.10でAndroid開発環境を作るTips>http://kghitokoto.blog113.fc2.com/blog-entry-70.html]] : 
 ”http://download.eclipse.org/releases/galileo/”をアップデートサイトに足してRestart eclipse
 
 : &color(purple){Android開発環境の整備は、いまだに eclipse のプラグイン導入の所でつまってる。。 ここのサイトで書いてあるとおりに galileo をアップデートサイトに追加すると、今度は矛盾してるよーとか言われてエラーになる。 いったん消していれなおしたほうがいいのかなぁ。。}; -- [[nakax]] &new{2012-09-13 (木) 16:32:52};
-[[Error message attempting to install Android ADT for Eclipse - Google グループ>https://groups.google.com/forum/?fromgroups=#!topic/android-ndk/eEuOUCZCL7Q]] : Cannot complete the install because one or more required items could not be found. : &color(purple){Linux の SDKでも同じエラーでとまってるわけですが。。CDTもいれればOKということでFAなのか}; -- [[nakax]] &new{2012-09-13 (木) 13:37:15};
--入れてもだめやな。eclipse で開発やったことない人には敷居が高い。 -- 2012-09-13 (木) 13:43:52
-[[全殺TAS ‐ ニコニコ動画(原宿)>http://www.nicovideo.jp/mylist/33163535]] : マリオ3 敵を全て倒します : &color(purple){スタイリッシュ虐殺。実に爽快w}; -- [[nakax]] &new{2012-09-13 (木) 12:26:28};
-[[熱発電チューブ 世界初の実用化にめど NHKニュース>http://www3.nhk.or.jp/news/html/20120912/k10014957071000.html]] : &color(purple){熱を通す発電とかどういう原理なのか}; -- [[nakax]] &new{2012-09-13 (木) 11:36:04};
--[[世界初、傾斜積層構造を用いた熱発電チューブを開発 | プレスリリース | ニュース | パナソニック企業情報 | Panasonic>http://panasonic.co.jp/corp/news/official.data/data.dir/jn110620-2/jn110620-2.html#2]] : &color(purple){熱で発電するってのは、以前からろうそく燃やして発電みたいのであった気がするんだが、温泉地等でも使えるようなのはかなりよさげだよなぁ}; -- [[nakax]] &new{2012-09-13 (木) 17:46:03};
-[[Androidでもブックマークレットを使えるようにしよう | あんどろいどスマート>http://android-smart.com/2011/06/android%E3%81%A7%E3%82%82%E3%83%96%E3%83%83%E3%82%AF%E3%83%9E%E3%83%BC%E3%82%AF%E3%83%AC%E3%83%83%E3%83%88%E3%82%92%E4%BD%BF%E3%81%88%E3%82%8B%E3%82%88%E3%81%86%E3%81%AB%E3%81%97%E3%82%88%E3%81%86.html]] : &color(purple){なるほど その手があったか}; -- [[nakax]] &new{2012-09-13 (木) 11:27:49};
-
//** &new{now ?};
~

**最新の Eclipse 4.2.0をいれると 2012-09-13 (木) 17:35:15 [#k6e4c450]
最初からリポジトリにいろいろ入ってるな。~
んで、ふつーに、エラーなくインストール開始できたわ。。~
~
2012-09-13 (木) 18:09:11~
途中で、
 Warning: You are installing software that contains unsigned content. 
  The authenticity or validity of this software cannot be established.
  Do you want to continue with the installation?
とか聞かれたが。とりあえず OK する。
~
2012-09-13 (木) 20:07:10~
/etc/udev/rules.d/51-android.rules 新規作成、以下の内容を入れる~
 SUBSYSTEM=="usb", ATTR{idVendor}=="04da", MODE="0666", GROUP="plugdev"
04da は Panasonic の ベンダーID(だとおもわれ)~
~
P-01D本体 設定→アプリケーション→開発→USBデバッグをON
~
サンプルの "Hello World" P-01D 実機で動きました。
~
~
って、ようやくスタートラインかよ!w~
~

**Android 開発環境 2012-09-13 (木) 16:42:52 [#b3ea2849]
ubuntu12.04LTS の apt-get でインストールした eclipse は 3.7.2 やね ~
現状のエラー。~
 Cannot complete the install because of a conflicting dependency.
  Software being installed: Android Development Tools 20.0.3.v201208082019-427395
     (com.android.ide.eclipse.adt.feature.group 20.0.3.v201208082019-427395)
  Software currently installed: Eclipse CVS Client 1.3.100.dist-7B78FHl9exZ_ 
     (org.eclipse.cvs.feature.group 1.3.100.dist-7B78FHl9exZ_)
  Only one of the following can be installed at once: 
    International Components for Unicode for Java (ICU4J) 4.4.2.v20110823
         (com.ibm.icu 4.4.2.v20110823)
    International Components for Unicode for Java (ICU4J) 4.0.1.v20090822
         (com.ibm.icu 4.0.1.v20090822)
  Cannot satisfy dependency:
    From: Android Development Tools 20.0.3.v201208082019-427395
      (com.android.ide.eclipse.adt.feature.group 20.0.3.v201208082019-427395)
    To: org.eclipse.wst.sse.ui 0.0.0
  Cannot satisfy dependency:
    From: Eclipse CVS Client 1.3.100.dist-7B78FHl9exZ_
      (org.eclipse.cvs.feature.group 1.3.100.dist-7B78FHl9exZ_)
    To: org.eclipse.platform.feature.group 3.7.0
  Cannot satisfy dependency:
    From: Java EMF Model Utilities 2.0.201.v201001252130
          (org.eclipse.jem.util 2.0.201.v201001252130)
    To: bundle com.ibm.icu [3.8.1.1,4.1.0)
  Cannot satisfy dependency:
    From: Eclipse Platform 3.7.2.dist-9nF7UHagFqn9pElwWhC90gLz-soEuSGYmtSeiRH
      (org.eclipse.platform.feature.group 3.7.2.dist-9nF7UHagFqn9pElwWhC90gLz-soEuSGYmtSeiRH)
    To: org.eclipse.rcp.feature.group [3.7.2.dist-8R9GFpOFUdy-521934]
  Cannot satisfy dependency:
    From: Eclipse RCP 3.7.2.dist-8R9GFpOFUdy-521934
      (org.eclipse.rcp.feature.group 3.7.2.dist-8R9GFpOFUdy-521934)
    To: com.ibm.icu [4.4.2.v20110823]
  Cannot satisfy dependency:
    From: Common Frameworks 1.1.300.v200904160730
       (org.eclipse.wst.common.frameworks 1.1.300.v200904160730)
    To: bundle org.eclipse.jem.util [2.0.100,3.0.0)
  Cannot satisfy dependency:
    From: Structured Source Editor 1.1.102.v200910200227
       (org.eclipse.wst.sse.ui 1.1.102.v200910200227)
    To: bundle org.eclipse.wst.validation [1.2.0,1.3.0)
  Cannot satisfy dependency:
    From: Validation Framework 1.2.104.v200911120201
      (org.eclipse.wst.validation 1.2.104.v200911120201)
    To: bundle org.eclipse.wst.common.frameworks [1.1.200,2.0.0)

** 椅子修理つづき &new{2012-09-13 (木) 08:44:40}; [#kd44075f]
昨日はつかれて途中で切り上げたので今日はその続き。~
~
~
2012-09-13 (木) 16:29:32~
#ref(P1000016-784248260.JPG,,30%)
とりあえず直った。~
木材を切ったり、穴あけたりが結構大変だった。~
~
~
~
~

**コメント [#k9471cbe]
#pcomment(,,reply)

トップ   編集 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS